import re
regex = re.compile(r"(?<=\S) +(?=\S)", flags=re.MULTILINE)
test_str = ("normal string foo bar qux\n"
" leading spaces are ok\n"
" trailing spaces are not affected ")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)