$re = '/(?<=\S) +(?=\S)/m';
$str = 'normal string foo bar qux
leading spaces are ok
trailing spaces are not affected ';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;