import Foundation
let pattern = #"(?<=\S) +(?=\S)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
normal string foo bar qux
leading spaces are ok
trailing spaces are not affected
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)