re = /(?<=\S) +(?=\S)/m
str = 'normal string foo bar qux
leading spaces are ok
trailing spaces are not affected '
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result