const regex = /(?<=\S) +(?=\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\S) +(?=\\S)', 'gm')
const str = `normal string foo bar qux
leading spaces are ok
trailing spaces are not affected `;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);