using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\S) +(?=\S)";
string substitution = @" ";
string input = @"normal string foo bar qux
leading spaces are ok
trailing spaces are not affected ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}