#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\S) +(?=\S)"
Local $sString = "normal string foo bar qux" & @CRLF & _
" leading spaces are ok" & @CRLF & _
" trailing spaces are not affected "
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)