# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(VisibileWeb)( != true Or IsNull\(\[CampoDinam)([^.]*)/[CampoDinam$3.$1]$2$3/gm;t' <<< "VisibileWeb != true Or IsNull([CampoDinam01.
VisibileWeb != true Or IsNull([CampoDinam02.
VisibileWeb != true Or IsNull([CampoDinam05."