# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(VisibileWeb)( != true Or IsNull\(\[CampoDinam)([^.]*)"
test_str = ("VisibileWeb != true Or IsNull([CampoDinam01.\n"
"VisibileWeb != true Or IsNull([CampoDinam02.\n"
"VisibileWeb != true Or IsNull([CampoDinam05.")
subst = "[CampoDinam$3.$1]$2$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.