re = /(VisibileWeb)( != true Or IsNull\(\[CampoDinam)([^.]*)/m
str = 'VisibileWeb != true Or IsNull([CampoDinam01.
VisibileWeb != true Or IsNull([CampoDinam02.
VisibileWeb != true Or IsNull([CampoDinam05.'
subst = '[CampoDinam$3.$1]$2$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result