const regex = /(VisibileWeb)( != true Or IsNull\(\[CampoDinam)([^.]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(VisibileWeb)( != true Or IsNull\\(\\[CampoDinam)([^.]*)', 'gm')
const str = `VisibileWeb != true Or IsNull([CampoDinam01.
VisibileWeb != true Or IsNull([CampoDinam02.
VisibileWeb != true Or IsNull([CampoDinam05.`;
const subst = `[CampoDinam$3.$1]$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);