import Foundation
let pattern = #"(VisibileWeb)( != true Or IsNull\(\[CampoDinam)([^.]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
VisibileWeb != true Or IsNull([CampoDinam01.
VisibileWeb != true Or IsNull([CampoDinam02.
VisibileWeb != true Or IsNull([CampoDinam05.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[CampoDinam$3.$1]$2$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)