using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(VisibileWeb)( != true Or IsNull\(\[CampoDinam)([^.]*)";
string substitution = @"[CampoDinam$3.$1]$2$3";
string input = @"VisibileWeb != true Or IsNull([CampoDinam01.
VisibileWeb != true Or IsNull([CampoDinam02.
VisibileWeb != true Or IsNull([CampoDinam05.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}