// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(VisibileWeb)( != true Or IsNull\(\[CampoDinam)([^.]*)").unwrap();
let string = "VisibileWeb != true Or IsNull([CampoDinam01.
VisibileWeb != true Or IsNull([CampoDinam02.
VisibileWeb != true Or IsNull([CampoDinam05.";
let substitution = "[CampoDinam$3.$1]$2$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}