use strict;
my $str = 'VisibileWeb != true Or IsNull([CampoDinam01.
VisibileWeb != true Or IsNull([CampoDinam02.
VisibileWeb != true Or IsNull([CampoDinam05.';
my $regex = qr/(VisibileWeb)( != true Or IsNull\(\[CampoDinam)([^.]*)/mp;
my $subst = '[CampoDinam$3.$1]$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";