#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^|\r\n]*)[\r\n]*\|[\r\n]*([^|\r\n]*)[\r\n]*\|[\r\n]*([^|\r\n]*)[\r\n]*\|[\r\n]*"
Local $sString = "Record 1|" & @CRLF & _
"Data|Commments|" & @CRLF & _
"Record 2|Some data|Notes|" & @CRLF & _
"Record 3|Data|" & @CRLF & _
"|" & @CRLF & _
"Record 4|Some data|Comments|" & @CRLF & _
"Record 5|Data|" & @CRLF & _
"|" & @CRLF & _
"Record 6|Some Data|Some Comments|"
Local $sSubst = "$1|$2|$3|\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)