// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^|\r\n]*)[\r\n]*\|[\r\n]*([^|\r\n]*)[\r\n]*\|[\r\n]*([^|\r\n]*)[\r\n]*\|[\r\n]*").unwrap();
let string = "Record 1|
Data|Commments|
Record 2|Some data|Notes|
Record 3|Data|
|
Record 4|Some data|Comments|
Record 5|Data|
|
Record 6|Some Data|Some Comments|";
let substitution = "$1|$2|$3|\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}