const regex = /(?m)^([^|\r\n]*)[\r\n]*\|[\r\n]*([^|\r\n]*)[\r\n]*\|[\r\n]*([^|\r\n]*)[\r\n]*\|[\r\n]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^([^|\\r\\n]*)[\\r\\n]*\\|[\\r\\n]*([^|\\r\\n]*)[\\r\\n]*\\|[\\r\\n]*([^|\\r\\n]*)[\\r\\n]*\\|[\\r\\n]*', 'g')
const str = `Record 1|
Data|Commments|
Record 2|Some data|Notes|
Record 3|Data|
|
Record 4|Some data|Comments|
Record 5|Data|
|
Record 6|Some Data|Some Comments|`;
const subst = `$1|$2|$3|\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);