re = /(?m)^([^|\r\n]*)[\r\n]*\|[\r\n]*([^|\r\n]*)[\r\n]*\|[\r\n]*([^|\r\n]*)[\r\n]*\|[\r\n]*/
str = 'Record 1|
Data|Commments|
Record 2|Some data|Notes|
Record 3|Data|
|
Record 4|Some data|Comments|
Record 5|Data|
|
Record 6|Some Data|Some Comments|'
subst = '$1|$2|$3|\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result