using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^([^|\r\n]*)[\r\n]*\|[\r\n]*([^|\r\n]*)[\r\n]*\|[\r\n]*([^|\r\n]*)[\r\n]*\|[\r\n]*";
string substitution = @"$1|$2|$3|\n";
string input = @"Record 1|
Data|Commments|
Record 2|Some data|Notes|
Record 3|Data|
|
Record 4|Some data|Comments|
Record 5|Data|
|
Record 6|Some Data|Some Comments|";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}