import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^([^|\\r\\n]*)[\\r\\n]*\\|[\\r\\n]*([^|\\r\\n]*)[\\r\\n]*\\|[\\r\\n]*([^|\\r\\n]*)[\\r\\n]*\\|[\\r\\n]*";
final String string = "Record 1|\n"
+ "Data|Commments|\n"
+ "Record 2|Some data|Notes|\n"
+ "Record 3|Data|\n"
+ "|\n"
+ "Record 4|Some data|Comments|\n"
+ "Record 5|Data|\n"
+ "|\n"
+ "Record 6|Some Data|Some Comments|";
final String subst = "$1|$2|$3|\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}