import Foundation
let pattern = #"(?m)^([^|\r\n]*)[\r\n]*\|[\r\n]*([^|\r\n]*)[\r\n]*\|[\r\n]*([^|\r\n]*)[\r\n]*\|[\r\n]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Record 1|
Data|Commments|
Record 2|Some data|Notes|
Record 3|Data|
|
Record 4|Some data|Comments|
Record 5|Data|
|
Record 6|Some Data|Some Comments|
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1|$2|$3|\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)