use strict;
my $str = 'Record 1|
Data|Commments|
Record 2|Some data|Notes|
Record 3|Data|
|
Record 4|Some data|Comments|
Record 5|Data|
|
Record 6|Some Data|Some Comments|';
my $regex = qr/(?m)^([^|\r\n]*)[\r\n]*\|[\r\n]*([^|\r\n]*)[\r\n]*\|[\r\n]*([^|\r\n]*)[\r\n]*\|[\r\n]*/p;
my $subst = '$1|$2|$3|\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";