# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)^([^|\r\n]*)[\r\n]*\|[\r\n]*([^|\r\n]*)[\r\n]*\|[\r\n]*([^|\r\n]*)[\r\n]*\|[\r\n]*"
test_str = ("Record 1|\n"
"Data|Commments|\n"
"Record 2|Some data|Notes|\n"
"Record 3|Data|\n"
"|\n"
"Record 4|Some data|Comments|\n"
"Record 5|Data|\n"
"|\n"
"Record 6|Some Data|Some Comments|")
subst = "$1|$2|$3|\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.