#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?<pat>[whlb])(?:\s*x\s*(?<pat>[whlb]))+\b"
Local $sString = "The measurements are (w x h x l): 5x7x3cm" & @CRLF & _
"The measurements, in form wxhxl: 5x7x3cm" & @CRLF & _
"Measurement options are (wxhxl), (hxlxb): Some random stuff" & @CRLF & _
"w x h x l x l x h"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")