re = /\b(?<pat>[whlb])(?:\s*x\s*(?<pat>[whlb]))+\b/m
str = 'The measurements are (w x h x l): 5x7x3cm
The measurements, in form wxhxl: 5x7x3cm
Measurement options are (wxhxl), (hxlxb): Some random stuff
w x h x l x l x h'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end