const regex = new RegExp('\\b(?<pat>[whlb])(?:\\s*x\\s*(?<pat>[whlb]))+\\b', 'gm')
const str = `The measurements are (w x h x l): 5x7x3cm
The measurements, in form wxhxl: 5x7x3cm
Measurement options are (wxhxl), (hxlxb): Some random stuff
w x h x l x l x h`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}