using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?<pat>[whlb])(?:\s*x\s*(?<pat>[whlb]))+\b";
string input = @"The measurements are (w x h x l): 5x7x3cm
The measurements, in form wxhxl: 5x7x3cm
Measurement options are (wxhxl), (hxlxb): Some random stuff
w x h x l x l x h";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}