import re
regex = re.compile(r"\b(?<pat>[whlb])(?:\s*x\s*(?<pat>[whlb]))+\b", flags=re.MULTILINE)
test_str = ("The measurements are (w x h x l): 5x7x3cm\n"
"The measurements, in form wxhxl: 5x7x3cm\n"
"Measurement options are (wxhxl), (hxlxb): Some random stuff\n"
"w x h x l x l x h")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")