import Foundation
let pattern = #"\b(?<pat>[whlb])(?:\s*x\s*(?<pat>[whlb]))+\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
The measurements are (w x h x l): 5x7x3cm
The measurements, in form wxhxl: 5x7x3cm
Measurement options are (wxhxl), (hxlxb): Some random stuff
w x h x l x l x h
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)