// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?<pat>[whlb])(?:\s*x\s*(?<pat>[whlb]))+\b").unwrap();
let string = "The measurements are (w x h x l): 5x7x3cm
The measurements, in form wxhxl: 5x7x3cm
Measurement options are (wxhxl), (hxlxb): Some random stuff
w x h x l x l x h";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}