import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<pat>[whlb])(?:\\s*x\\s*(?<pat>[whlb]))+\\b";
final String string = "The measurements are (w x h x l): 5x7x3cm\n"
+ "The measurements, in form wxhxl: 5x7x3cm\n"
+ "Measurement options are (wxhxl), (hxlxb): Some random stuff\n"
+ "w x h x l x l x h";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}