# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[([A-Z]*(?:(?:.*|\h*)[A-Z0-9][a-z]*)*)\]/$1\:/gm;t' <<< "Exclude the following:
[Ki-Woo]
[Drunk]
[Woman 1]
[Dr. Freeman]
[Dr. West]
[Anne Marie O'Donnell]
[Anne-Marie O'Donnell]
[Gary Wells]
[Gary L. Wells]
[R. H. Brown]
[Roger H. Brown]
[J. Edgar Hover]
Exclude ones starting with lowercase:
[young Ashley]
[reporter 1]
[woman 1]"