import Foundation
let pattern = #"\[([A-Z]*(?:(?:.*|\h*)[A-Z0-9][a-z]*)*)\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Exclude the following:
[Ki-Woo]
[Drunk]
[Woman 1]
[Dr. Freeman]
[Dr. West]
[Anne Marie O'Donnell]
[Anne-Marie O'Donnell]
[Gary Wells]
[Gary L. Wells]
[R. H. Brown]
[Roger H. Brown]
[J. Edgar Hover]
Exclude ones starting with lowercase:
[young Ashley]
[reporter 1]
[woman 1]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\:"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)