import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([A-Z]*(?:(?:.*|\\h*)[A-Z0-9][a-z]*)*)\\]";
final String string = "Exclude the following:\n"
+ "[Ki-Woo]\n"
+ "[Drunk]\n"
+ "[Woman 1]\n"
+ "[Dr. Freeman]\n"
+ "[Dr. West]\n"
+ "[Anne Marie O'Donnell]\n"
+ "[Anne-Marie O'Donnell]\n"
+ "[Gary Wells]\n"
+ "[Gary L. Wells]\n"
+ "[R. H. Brown]\n"
+ "[Roger H. Brown]\n"
+ "[J. Edgar Hover]\n"
+ "Exclude ones starting with lowercase:\n"
+ "[young Ashley]\n"
+ "[reporter 1]\n"
+ "[woman 1]";
final String subst = "$1\\:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}