$re = '/\[([A-Z]*(?:(?:.*|\h*)[A-Z0-9][a-z]*)*)\]/m';
$str = 'Exclude the following:
[Ki-Woo]
[Drunk]
[Woman 1]
[Dr. Freeman]
[Dr. West]
[Anne Marie O\'Donnell]
[Anne-Marie O\'Donnell]
[Gary Wells]
[Gary L. Wells]
[R. H. Brown]
[Roger H. Brown]
[J. Edgar Hover]
Exclude ones starting with lowercase:
[young Ashley]
[reporter 1]
[woman 1]';
$subst = "$1\:";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;