using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([A-Z]*(?:(?:.*|\h*)[A-Z0-9][a-z]*)*)\]";
string substitution = @"$1\:";
string input = @"Exclude the following:
[Ki-Woo]
[Drunk]
[Woman 1]
[Dr. Freeman]
[Dr. West]
[Anne Marie O'Donnell]
[Anne-Marie O'Donnell]
[Gary Wells]
[Gary L. Wells]
[R. H. Brown]
[Roger H. Brown]
[J. Edgar Hover]
Exclude ones starting with lowercase:
[young Ashley]
[reporter 1]
[woman 1]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}