import re
regex = re.compile(r"\[([A-Z]*(?:(?:.*|\h*)[A-Z0-9][a-z]*)*)\]", flags=re.MULTILINE)
test_str = ("Exclude the following:\n"
"[Ki-Woo]\n"
"[Drunk]\n"
"[Woman 1]\n"
"[Dr. Freeman]\n"
"[Dr. West]\n"
"[Anne Marie O'Donnell]\n"
"[Anne-Marie O'Donnell]\n"
"[Gary Wells]\n"
"[Gary L. Wells]\n"
"[R. H. Brown]\n"
"[Roger H. Brown]\n"
"[J. Edgar Hover]\n"
"Exclude ones starting with lowercase:\n"
"[young Ashley]\n"
"[reporter 1]\n"
"[woman 1]")
subst = "$1\\:"
result = regex.sub(subst, test_str)
if result:
print(result)