use strict;
my $str = 'Exclude the following:
[Ki-Woo]
[Drunk]
[Woman 1]
[Dr. Freeman]
[Dr. West]
[Anne Marie O\'Donnell]
[Anne-Marie O\'Donnell]
[Gary Wells]
[Gary L. Wells]
[R. H. Brown]
[Roger H. Brown]
[J. Edgar Hover]
Exclude ones starting with lowercase:
[young Ashley]
[reporter 1]
[woman 1]';
my $regex = qr/\[([A-Z]*(?:(?:.*|\h*)[A-Z0-9][a-z]*)*)\]/mp;
my $subst = '$1\\:';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";