const regex = /\[([A-Z]*(?:(?:.*|\h*)[A-Z0-9][a-z]*)*)\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([A-Z]*(?:(?:.*|\\h*)[A-Z0-9][a-z]*)*)\\]', 'gm')
const str = `Exclude the following:
[Ki-Woo]
[Drunk]
[Woman 1]
[Dr. Freeman]
[Dr. West]
[Anne Marie O'Donnell]
[Anne-Marie O'Donnell]
[Gary Wells]
[Gary L. Wells]
[R. H. Brown]
[Roger H. Brown]
[J. Edgar Hover]
Exclude ones starting with lowercase:
[young Ashley]
[reporter 1]
[woman 1]`;
const subst = `$1\:`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);