#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:R(?:89(?:1(?:[13]0|29|45)|052)|11(?:0[23]|70)))"
Local $sString = "R1102" & @CRLF & _
"R1170" & @CRLF & _
"R1103" & @CRLF & _
"R89052" & @CRLF & _
"R89110" & @CRLF & _
"R89129" & @CRLF & _
"R89130" & @CRLF & _
"R89145" & @CRLF & _
"R891425" & @CRLF & _
"Q1103" & @CRLF & _
"RQ1103" & @CRLF & _
"RR890529" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")