use strict;
my $str = 'R1102
R1170
R1103
R89052
R89110
R89129
R89130
R89145
R891425
Q1103
RQ1103
RR890529
';
my $regex = qr/(?:R(?:89(?:1(?:[13]0|29|45)|052)|11(?:0[23]|70)))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}