$re = '/(?:R(?:89(?:1(?:[13]0|29|45)|052)|11(?:0[23]|70)))/';
$str = 'R1102
R1170
R1103
R89052
R89110
R89129
R89130
R89145
R891425
Q1103
RQ1103
RR890529
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);