#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\{)(?=.*?\"t\"\s*:\s*2).*?(?=\})"
Local $sString = "{"location":[22.99902,66.000],"t":1}," & @CRLF & _
"{"location":[55.32168,140.556],"t":2}," & @CRLF & _
"{"location":[85.0002,20.0055],"t":3}," & @CRLF & _
"{"location": [4, 4], "smth": val, "t":2}," & @CRLF & _
"{"t": 2, "location": [value2], "something else": some_value}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")