import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\{)(?=.*?\\\"t\\\"\\s*:\\s*2).*?(?=\\})";
final String string = "{\"location\":[22.99902,66.000],\"t\":1},\n"
+ "{\"location\":[55.32168,140.556],\"t\":2},\n"
+ "{\"location\":[85.0002,20.0055],\"t\":3},\n"
+ "{\"location\": [4, 4], \"smth\": val, \"t\":2},\n"
+ "{\"t\": 2, \"location\": [value2], \"something else\": some_value}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}