# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\{)(?=.*?\"t\"\s*:\s*2).*?(?=\})"
test_str = ("{\"location\":[22.99902,66.000],\"t\":1},\n"
"{\"location\":[55.32168,140.556],\"t\":2},\n"
"{\"location\":[85.0002,20.0055],\"t\":3},\n"
"{\"location\": [4, 4], \"smth\": val, \"t\":2},\n"
"{\"t\": 2, \"location\": [value2], \"something else\": some_value}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.