import Foundation
let pattern = #"(?<=\{)(?=.*?\"t\"\s*:\s*2).*?(?=\})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{"location":[22.99902,66.000],"t":1},
{"location":[55.32168,140.556],"t":2},
{"location":[85.0002,20.0055],"t":3},
{"location": [4, 4], "smth": val, "t":2},
{"t": 2, "location": [value2], "something else": some_value}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)