using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\{)(?=.*?\""t\""\s*:\s*2).*?(?=\})";
string input = @"{""location"":[22.99902,66.000],""t"":1},
{""location"":[55.32168,140.556],""t"":2},
{""location"":[85.0002,20.0055],""t"":3},
{""location"": [4, 4], ""smth"": val, ""t"":2},
{""t"": 2, ""location"": [value2], ""something else"": some_value}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}