$re = '/(?<=\{)(?=.*?\"t\"\s*:\s*2).*?(?=\})/m';
$str = '{"location":[22.99902,66.000],"t":1},
{"location":[55.32168,140.556],"t":2},
{"location":[85.0002,20.0055],"t":3},
{"location": [4, 4], "smth": val, "t":2},
{"t": 2, "location": [value2], "something else": some_value}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);