re = /(?<=\{)(?=.*?\"t\"\s*:\s*2).*?(?=\})/m
str = '{"location":[22.99902,66.000],"t":1},
{"location":[55.32168,140.556],"t":2},
{"location":[85.0002,20.0055],"t":3},
{"location": [4, 4], "smth": val, "t":2},
{"t": 2, "location": [value2], "something else": some_value}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end